PureBasic Forum
http://forums.purebasic.com/english/

Application Doesnt Run In Mint 19.1<Solved>
http://forums.purebasic.com/english/viewtopic.php?f=15&t=72035
Page 1 of 1

Author:  collectordave [ Fri Jan 04, 2019 10:47 am ]
Post subject:  Application Doesnt Run In Mint 19.1<Solved>

Hi All,

New to linux. Have programmed an application which runs perfectly on UBUNTU 16.something and on mint 18.1LTS (32 bit) no changes.

Supplied Application to a customer who is running Mint 19.1.

The application just shows a blank screen!

Am I missing some dependencies or whatever that I need to get prople to install?

Regards

CD

Author:  Shardik [ Fri Jan 04, 2019 11:13 am ]
Post subject:  Re: Application Doesnt Run In Mint 19.1

Since your application runs on Linux Mint 18.1 32-bit, it must be a 32-bit application. 32-bit installations on Linux are uncommon, most Linux installations are 64-bit. A 64-bit Linux installation can normally only execute 64-bit programs (in contrast to MacOS and Windows). One solution would be to install 32-bit compatibility libraries on a 64-bit Linux system but this is very tricky and the success not guaranteed. So I presume your customer with Linux Mint 19.1 uses a 64-bit installation. So I would advise to compile your PureBasic program on a 64-bit Linux and let your customer try out the 64-bit version.

So in essence for Linux you always have to provide a 32-bit and 64-bit version of your application whereas a 32-bit application will suffice for all MacOS and Windows systems. But be aware that the current MacOS version Mohave will be the last one to support 32-bit apps.

Author:  collectordave [ Fri Jan 04, 2019 3:38 pm ]
Post subject:  Re: Application Doesnt Run In Mint 19.1

Thanks Shardik

I will get on with it right away!

Regards

CD

Author:  collectordave [ Sun Jan 06, 2019 4:24 pm ]
Post subject:  Re: Application Doesnt Run In Mint 19.1

Hi All

Managed to get Mint 19.1 64bit working installed PB5.7 and the ide ran straightaway.

First compile had a list of linker errors as long as my arm did some of the sudo apt gets etc and the list reduced to something less than war and peace but trying more I get this from terminal:-

The following packages have unmet dependencies:
libgtk-3-dev : Depends: libglib2.0-dev (>= 2.49.4) but it is not going to be installed
Depends: libgdk-pixbuf2.0-dev (>= 2.30.0) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.40.5) but it is not going to be installed
Depends: libatk1.0-dev (>= 2.15.1) but it is not going to be installed
Depends: libatk-bridge2.0-dev but it is not going to be installed
Depends: libcairo2-dev (>= 1.14.0) but it is not going to be installed
Depends: libfontconfig1-dev but it is not going to be installed
Depends: libx11-dev but it is not going to be installed
Depends: libxext-dev but it is not going to be installed
Depends: libxinerama-dev but it is not going to be installed
Depends: libxi-dev but it is not going to be installed
Depends: libxrandr-dev but it is not going to be installed
Depends: libxcursor-dev but it is not going to be installed
Depends: libxfixes-dev but it is not going to be installed
Depends: libxcomposite-dev but it is not going to be installed
Depends: libxdamage-dev but it is not going to be installed
Depends: libegl1-mesa-dev but it is not going to be installed
Depends: libxkbcommon-dev but it is not going to be installed
libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.27.3) but it is not going to be installed
Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed
Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
Depends: libx11-dev (>= 2:1.0.0-6) but it is not going to be installed
Depends: libxext-dev (>= 1:1.0.1-2) but it is not going to be installed
Depends: libxinerama-dev (>= 1:1.0.1-4.1) but it is not going to be installed
Depends: libxi-dev (>= 1:1.0.1-4) but it is not going to be installed
Depends: libxrandr-dev (>= 2:1.2.99) but it is not going to be installed
Depends: libxcursor-dev but it is not going to be installed
Depends: libxfixes-dev (>= 1:3.0.0-3) but it is not going to be installed
Depends: libxcomposite-dev (>= 1:0.2.0-3) but it is not going to be installed
Depends: libxdamage-dev (>= 1:1.0.1-3) but it is not going to be installed
libwebkit2gtk-4.0-dev : Depends: libwebkit2gtk-4.0-37 (= 2.20.1-1) but 2.22.4-0ubuntu0.18.04.1 is to be installed
Depends: gir1.2-webkit2-4.0 (= 2.20.1-1) but 2.22.4-0ubuntu0.18.04.1 is to be installed
Depends: libsoup2.4-dev (>= 2.40) but it is not going to be installed
Depends: libjavascriptcoregtk-4.0-dev (= 2.20.1-1) but it is not going to be installed
libwebkitgtk-3.0-dev : Depends: libsoup2.4-dev (>= 2.40) but it is not going to be installed
libwebkitgtk-dev : Depends: libsoup2.4-dev (>= 2.42) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Can anyone make sense of that?

Author:  ccode [ Sun Jan 06, 2019 4:51 pm ]
Post subject:  Re: Application Doesnt Run In Mint 19.1

I can recommend for all Linux beginners "Manjaro" Linux.
This applies to all those who would like to try PureBasic under Linux and have a bad internet connection and little patience.

Author:  mk-soft [ Sun Jan 06, 2019 5:00 pm ]
Post subject:  Re: Application Doesnt Run In Mint 19.1

You forget installed developers packets...
Quote:
Purebasic
---------
sudo apt-get install build-essential gcc g++

sudo apt-get install libxxf86vm-dev libxine2-dev unixodbc-dev libsdl1.2-dev libsdl2-dev

sudo apt-get install libgtk2.0-dev libgtk-3-dev libwebkitgtk-dev libwebkitgtk-3.0-dev libwebkit2gtk-4.0-dev


Subsystem qt
------------
sudo apt-get install qtbase5-dev qttools5-dev qtmultimedia5-dev qtdeclarative5-dev libqt5svg5-dev libqt5webkit5-dev libqt5multimedia5-plugins


Ubuntu Gnome 18.xx (For PB-IDE)
-------------------------------
sudo apt install libcanberra-gtk-module

Obsoleted
---------
;sudo apt-get install libgnome2-dev
;sudo apt-get install libgnomeprintui2.2-dev libxine-dev


Ubuntu missing default libs (Without developer packets)
-------------------------------------------------------
gtk2
- sudo apt-get install libgtk2.0
gtk3
- sudo apt-get install libwebkitgtk-3.0
qt
- sudo apt install qt5-default

Author:  collectordave [ Mon Jan 07, 2019 3:42 am ]
Post subject:  Re: Application Doesnt Run In Mint 19.1

All the above tried and still get the same problems even when doing the sudo apt-get exactly as shown in mksoft post.

Author:  collectordave [ Mon Jan 07, 2019 5:55 am ]
Post subject:  Re: Application Doesnt Run In Mint 19.1

Tried

sudo apt-get install build essential

Then all of them again and it worked.

The only thing is if I select project options the whole IDE crashes should I post this as a bug?

Author:  collectordave [ Wed Jan 09, 2019 6:21 am ]
Post subject:  Re: Application Doesnt Run In Mint 19.1<Solved>

The last part is I did a 32 bit application which doesn't run on 64 bit linux systems.

Downloaded 64 bit PB recompilede and all Ok.

Thanks to all

CD

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/