It is currently Sat Jul 11, 2020 6:08 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Problems with DisplayShadowSprite
PostPosted: Sat Jan 17, 2004 2:58 pm 
Offline
User
User

Joined: Sat Jan 03, 2004 7:25 pm
Posts: 26
Location: Rinteln
When i try to compile this code:
Code:
If InitSprite() = 0 Or InitKeyboard() = 0 Or OpenScreen(1024, 769, 32, "") = 0
   End
EndIf

CreateSprite(0, 32 ,32 , #PB_Sprite_Alpha|#PB_Sprite_Memory)

Repeat
   StartSpecialFX()   
   DisplayShadowSprite(0, 0, 0)
   StopSpecialFX()

   FlipBuffers()   
   ClearScreen(0, 0, 0)
   Delay(10)
   ExamineKeyboard()
Until KeyboardPushed(#PB_Key_Escape)

I get a error message:
Code:
******************************************
PureBasic Linux x86 v3.81
******************************************
                                                                                                   
Loading external modules...
Starting compilation...
17 lines processed.
Creating the executable.
purebasic.o: In function `main':
purebasic.o(.text+0xa8): undefined reference to `PB_DisplayShadowSprite'
collect2: ld returned 1 exit status
                                                                                                   
- Feel the ..PuRe.. Power -


Does anybody else have this problem?


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Jan 17, 2004 3:55 pm 
Offline
Enthusiast
Enthusiast
User avatar

Joined: Wed Apr 30, 2003 3:50 am
Posts: 310
Location: 3DoorsDown
Quote:
******************************************
PureBasic Linux x86 v3.81
******************************************

Loading external modules...
Starting compilation...
17 lines processed.
Creating the executable.
purebasic.o(.text+0xa8): In function `main':
: undefined reference to `PB_DisplayShadowSprite'
collect2: ld returned 1 exit status
same here, but I don't know anything about grafix programming. --jb

_________________
peace
[pI 166Mhz 32Mb w95]
[pII 350Mhz 256Mb atir3RagePro WinDoze '98 FE & 2k]
[Athlon 1.3Ghz 160Mb XPHome & RedHat9]


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Jan 18, 2004 12:06 pm 
Offline
Enthusiast
Enthusiast

Joined: Mon Dec 08, 2003 7:50 pm
Posts: 154
Location: Germany
A Bug! The function is missing. Same error message like in this thread

http://forums.purebasic.com/english/vie ... php?t=9029

But there was it the Round() function!

:(

regards,
christian


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Jan 18, 2004 1:18 pm 
Offline
User
User

Joined: Sat Jan 03, 2004 7:25 pm
Posts: 26
Location: Rinteln
I've got the same problem with DisplayAlphaSprite() and DrawImage(id , x,
y,,newwidthnewheight). And DrawingBufferPixelFormat() gives back 32, but none of the
#PB_PixelFormat_ constants has got the value 32 and i've got a problem with the #PB_Key_
constants : http://forums.purebasic.com/english/viewtopic.php?t=9076...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Jun 12, 2004 8:24 pm 
Offline
Administrator
Administrator

Joined: Fri May 17, 2002 4:39 pm
Posts: 14065
Location: France
I've added DisplayShadowSprite(), DisplayAlphaSprite() and fixed DrawingBufferPixelFormat(). About the DrawImage(), it will be an unsupported command for now, thanks to pointed it out.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye