It is currently Sun Mar 07, 2021 10:38 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: I can not get BASS Libraries working with PureBasic 5.21 ver
PostPosted: Sat Jan 25, 2014 2:20 am 
Offline
User
User

Joined: Mon Feb 25, 2013 3:04 pm
Posts: 55
I downloaded the BASS libraries from the web site un4seen.com
then had to take the types from the pointers and then put the files in the source directory.

I then ran the compiler and got linker problems.

Quote:
POLINK:error Unresolved external symbol "_BASS_Init"
POLINK:error Unresolved external symbol "_BASS_StreamCreateFile"
POLINK:error Unresolved external symbol "_BASS_ChannelPlay"
POLINK:fatal error: 3 unresolved external(s)


I tried creating a new project with all the files, but its the same.

is it the IDE settings?

Please help.


Top
 Profile  
Reply with quote  
 Post subject: Re: I can not get BASS Libraries working with PureBasic 5.21
PostPosted: Sat Jan 25, 2014 10:26 am 
Offline
Addict
Addict
User avatar

Joined: Tue Oct 09, 2007 2:15 am
Posts: 1156
it seems, that you use wrong function-names.

Try first compiler settings like Unicode off, (this is since 5.x standard), maybe this helps.

_________________
PureBasic 5.72 LTS (Windows x86/x64) | Windows10 Pro x64 | Z370 Extreme4 | i7 8770k | 64GB RAM | iChill GeForce RTX 2080 Super | HAF XF Evo​​
English is not my native language... (I often use DeepL to translate my texts.)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye