It is currently Thu Jan 28, 2021 12:04 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: [PureBasic IDE] Failed to load module "canberra-gtk-module"
PostPosted: Sun Mar 29, 2020 8:04 am 
Offline
Addict
Addict
User avatar

Joined: Tue Jul 22, 2003 5:02 pm
Posts: 1542
Location: In a long distant galaxy
Hi.

Using Ubuntu 18.04.4 LTS
Using PureBasic 5.71 or 5.72 b3

When starting PureBasic i get those messages in the terminal :

Code:
Gtk-Message: 08:55:55.272: Failed to load module "canberra-gtk-module"

** (purebasic:25289): CRITICAL **: 08:55:55.597: murrine_style_draw_box_gap: assertion 'height >= -1' failed
** (purebasic:25289): CRITICAL **: 08:55:55.780: murrine_style_draw_box_gap: assertion 'height >= -1' failed


Also i get visual glitches on the Linux desktop (some refresh issues).

_________________
No programming language is perfect. There is not even a single best language.
There are only languages well suited or perhaps poorly suited for particular purposes. Herbert Mayer


Top
 Profile  
Reply with quote  
 Post subject: Re: [PureBasic IDE] Failed to load module "canberra-gtk-modu
PostPosted: Sun Mar 29, 2020 9:46 am 
Offline
Addict
Addict
User avatar

Joined: Fri May 12, 2006 6:51 pm
Posts: 2820
Location: Germany
Install Canberra...
Quote:
Ubuntu Gnome 18.xx (For PB-IDE)
-------------------------------
sudo apt install libcanberra-gtk-module


My Developer packets.
Quote:
Purebasic
---------
sudo apt-get install build-essential gcc g++

sudo apt-get install libxxf86vm-dev libxine2-dev unixodbc-dev libsdl1.2-dev libsdl2-dev

sudo apt-get install libgtk2.0-dev libgtk-3-dev

sudo apt-get install libwebkitgtk-dev libwebkitgtk-3.0-dev libwebkit2gtk-4.0-dev


Subsystem qt
------------
sudo apt-get install qtbase5-dev qttools5-dev qtmultimedia5-dev qtdeclarative5-dev libqt5svg5-dev libqt5webkit5-dev libqt5multimedia5-plugins


Ubuntu Gnome 18.xx (For PB-IDE)
-------------------------------
sudo apt install libcanberra-gtk-module


Obsoleted
---------
;sudo apt-get install libgnome2-dev
;sudo apt-get install libgnomeprintui2.2-dev libxine-dev


Ubuntu missing default libs (Without developer packets)
-------------------------------------------------------
gtk2
- sudo apt-get install libgtk2.0
gtk3
- sudo apt-get install libwebkitgtk-3.0
qt
- sudo apt install qt5-default

_________________
My Projects ThreadToGUI / OOP-BaseClass / OOP-BaseClassDispatch / EventDesigner V3
PB v3.30 / v5.70 - OS Mac Mini OSX 10.xx - VM Window Pro / Linux Ubuntu
Downloads on my Webspace


Top
 Profile  
Reply with quote  
 Post subject: Re: [PureBasic IDE] Failed to load module "canberra-gtk-modu
PostPosted: Sun Mar 29, 2020 10:36 am 
Offline
Addict
Addict
User avatar

Joined: Tue Jul 22, 2003 5:02 pm
Posts: 1542
Location: In a long distant galaxy
Many thanks @mksoft :!:

Just updated all those packages.



We still get that non-blocking warning, though :

Code:
** (purebasic:25289): CRITICAL **: 08:55:55.780: murrine_style_draw_box_gap: assertion 'height >= -1' failed

_________________
No programming language is perfect. There is not even a single best language.
There are only languages well suited or perhaps poorly suited for particular purposes. Herbert Mayer


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye