PureBasic Forum
http://forums.purebasic.com/english/

Use the latest PellesC (9.00) on PureBasic 5.70 x64
http://forums.purebasic.com/english/viewtopic.php?f=3&t=71829
Page 1 of 1

Author:  IceSoft [ Wed Nov 28, 2018 10:51 am ]
Post subject:  Use the latest PellesC (9.00) on PureBasic 5.70 x64

Pelles C 9.00 final has been released (2018-08-22)

PureBasic x64 and PureBasic x86 should be go different now:

PB x86 supporting "old" Maschines and Windows 98 (more a bugfix live)
PB x64 is up to date and get new features.

Linux and MacOS are always 64bit only. I am right?

Author:  Bitblazer [ Wed Nov 28, 2018 11:57 am ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

IceSoft wrote:
Linux and MacOS are always 64bit only. I am right?


I am using linux x86 sometimes and Purebasic fully supports x86 and x64 on linux.

Author:  IceSoft [ Wed Nov 28, 2018 12:31 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Bitblazer wrote:
IceSoft wrote:
Linux and MacOS are always 64bit only. I am right?


I am using linux x86 sometimes and Purebasic fully supports x86 and x64 on linux.

Of course I have also an Windows98 machine but never plan to install/update actual SW on this machine ;-)
If I want develop an own SW I will use Visual Studio 6.0 and not VS2017 ;-)
Same for PureBasic ;-)

Author:  Bitblazer [ Wed Nov 28, 2018 12:58 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

IceSoft wrote:
Bitblazer wrote:
IceSoft wrote:
Linux and MacOS are always 64bit only. I am right?


I am using linux x86 sometimes and Purebasic fully supports x86 and x64 on linux.

Of course I have also an Windows98 machine but never plan to install/update actual SW on this machine ;-)


Then you basically dont use or more importantly you don't need it. I did just spend 4 hours on the linux 5.70 x86 version to fix a problem introduced by a security update.

I could certainly switch to x64 only with having x86 access via the PureBasic museum (5.62 and lower), but i am not sure about others in the embedded world.

Dropping x86 support there, would leave the customers in the same situation like XP users - basically easy prey for kids on the net.

Author:  IceSoft [ Wed Nov 28, 2018 1:26 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Bitblazer wrote:
Dropping x86 support there, would leave the customers in the same situation like XP users - basically easy prey for kids on the net.

That's life.
Same situation for all the good old 8bit computers ;-)

Author:  Dawgmann [ Mon Sep 09, 2019 8:25 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

@IceSoft

FYI... your desired outcome is easily attainable by copying and pasting the corresponding files from Pelles C to overwrite those in your PB installation like i did.

That way, you get what you want and PB still supports older machines on everyone else's system. Problem solved.

Author:  IceSoft [ Tue Sep 10, 2019 10:56 am ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Dawgmann wrote:
Problem solved.

It was never a problem. It's more a wish.
I overwriting the old PellesC file always on a "definied advanced PB 64bit" installation.

Author:  Dawgmann [ Tue Sep 10, 2019 2:29 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Ah...
I do the same. I'm truly beginning to love PB. I love Pelles C too, and have been using it for some time now.
Great stuff.
Pelle and Fred both have created remarkable development systems.

Author:  IceSoft [ Tue Sep 10, 2019 3:33 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Dawgmann wrote:
Pelle and Fred both have created remarkable development systems.

For me it is enough to use it sometimes.
I don't pray for it.

Author:  skywalk [ Tue Sep 10, 2019 3:56 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

I remember trying this before and getting an ASM error.
Why are you installing an updated PellesC when the PureBasic installer does not?

Author:  Everything [ Tue Sep 10, 2019 4:35 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

By the way, I could be wrong but some libs like zlib not latest versions too
Code:
; buildin 1.2.1.1 (9 January 2004)
; latest* 1.2.3.0 (18 July   2005) - 6 times updated (also with security fixes)

in this case it can be replaced safely just in place.

Author:  skywalk [ Tue Sep 10, 2019 4:56 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

PB v571 LTS x64 has latest zlib v1.2.11.

Author:  Everything [ Tue Sep 10, 2019 5:11 pm ]
Post subject:  Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Looks like you are right.

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/