Use the latest PellesC (9.00) on PureBasic 5.70 x64

Got an idea for enhancing PureBasic? New command(s) you'd like to see?
User avatar
IceSoft
Addict
Addict
Posts: 1508
Joined: Thu Jun 24, 2004 8:51 am
Location: Germany

Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by IceSoft »

Pelles C 9.00 final has been released (2018-08-22)

PureBasic x64 and PureBasic x86 should be go different now:

PB x86 supporting "old" Maschines and Windows 98 (more a bugfix live)
PB x64 is up to date and get new features.

Linux and MacOS are always 64bit only. I am right?
Belive!
<Wrapper>4PB, PB<game>, =QONK=, PetriDish, Movie2Image, PictureManager,...
Bitblazer
Enthusiast
Enthusiast
Posts: 444
Joined: Mon Apr 10, 2017 6:17 pm
Location: Germany
Contact:

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by Bitblazer »

IceSoft wrote:Linux and MacOS are always 64bit only. I am right?
I am using linux x86 sometimes and Purebasic fully supports x86 and x64 on linux.
User avatar
IceSoft
Addict
Addict
Posts: 1508
Joined: Thu Jun 24, 2004 8:51 am
Location: Germany

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by IceSoft »

Bitblazer wrote:
IceSoft wrote:Linux and MacOS are always 64bit only. I am right?
I am using linux x86 sometimes and Purebasic fully supports x86 and x64 on linux.
Of course I have also an Windows98 machine but never plan to install/update actual SW on this machine ;-)
If I want develop an own SW I will use Visual Studio 6.0 and not VS2017 ;-)
Same for PureBasic ;-)
Belive!
<Wrapper>4PB, PB<game>, =QONK=, PetriDish, Movie2Image, PictureManager,...
Bitblazer
Enthusiast
Enthusiast
Posts: 444
Joined: Mon Apr 10, 2017 6:17 pm
Location: Germany
Contact:

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by Bitblazer »

IceSoft wrote:
Bitblazer wrote:
IceSoft wrote:Linux and MacOS are always 64bit only. I am right?
I am using linux x86 sometimes and Purebasic fully supports x86 and x64 on linux.
Of course I have also an Windows98 machine but never plan to install/update actual SW on this machine ;-)
Then you basically dont use or more importantly you don't need it. I did just spend 4 hours on the linux 5.70 x86 version to fix a problem introduced by a security update.

I could certainly switch to x64 only with having x86 access via the PureBasic museum (5.62 and lower), but i am not sure about others in the embedded world.

Dropping x86 support there, would leave the customers in the same situation like XP users - basically easy prey for kids on the net.
User avatar
IceSoft
Addict
Addict
Posts: 1508
Joined: Thu Jun 24, 2004 8:51 am
Location: Germany

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by IceSoft »

Bitblazer wrote: Dropping x86 support there, would leave the customers in the same situation like XP users - basically easy prey for kids on the net.
That's life.
Same situation for all the good old 8bit computers ;-)
Belive!
<Wrapper>4PB, PB<game>, =QONK=, PetriDish, Movie2Image, PictureManager,...
Dawgmann
User
User
Posts: 40
Joined: Wed Jul 17, 2019 5:32 pm

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by Dawgmann »

@IceSoft

FYI... your desired outcome is easily attainable by copying and pasting the corresponding files from Pelles C to overwrite those in your PB installation like i did.

That way, you get what you want and PB still supports older machines on everyone else's system. Problem solved.
User avatar
IceSoft
Addict
Addict
Posts: 1508
Joined: Thu Jun 24, 2004 8:51 am
Location: Germany

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by IceSoft »

Dawgmann wrote: Problem solved.
It was never a problem. It's more a wish.
I overwriting the old PellesC file always on a "definied advanced PB 64bit" installation.
Belive!
<Wrapper>4PB, PB<game>, =QONK=, PetriDish, Movie2Image, PictureManager,...
Dawgmann
User
User
Posts: 40
Joined: Wed Jul 17, 2019 5:32 pm

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by Dawgmann »

Ah...
I do the same. I'm truly beginning to love PB. I love Pelles C too, and have been using it for some time now.
Great stuff.
Pelle and Fred both have created remarkable development systems.
User avatar
IceSoft
Addict
Addict
Posts: 1508
Joined: Thu Jun 24, 2004 8:51 am
Location: Germany

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by IceSoft »

Dawgmann wrote: Pelle and Fred both have created remarkable development systems.
For me it is enough to use it sometimes.
I don't pray for it.
Belive!
<Wrapper>4PB, PB<game>, =QONK=, PetriDish, Movie2Image, PictureManager,...
User avatar
skywalk
Addict
Addict
Posts: 3516
Joined: Wed Dec 23, 2009 10:14 pm
Location: Boston, MA

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by skywalk »

I remember trying this before and getting an ASM error.
Why are you installing an updated PellesC when the PureBasic installer does not?
The nice thing about standards is there are so many to choose from. ~ Andrew Tanenbaum
Everything
Enthusiast
Enthusiast
Posts: 210
Joined: Sat Jul 07, 2018 6:50 pm

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by Everything »

By the way, I could be wrong but some libs like zlib not latest versions too

Code: Select all

; buildin 1.2.1.1 (9 January 2004)
; latest* 1.2.3.0 (18 July   2005) - 6 times updated (also with security fixes)
in this case it can be replaced safely just in place.
User avatar
skywalk
Addict
Addict
Posts: 3516
Joined: Wed Dec 23, 2009 10:14 pm
Location: Boston, MA

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by skywalk »

PB v571 LTS x64 has latest zlib v1.2.11.
The nice thing about standards is there are so many to choose from. ~ Andrew Tanenbaum
Everything
Enthusiast
Enthusiast
Posts: 210
Joined: Sat Jul 07, 2018 6:50 pm

Re: Use the latest PellesC (9.00) on PureBasic 5.70 x64

Post by Everything »

Looks like you are right.
Post Reply