It is currently Wed Nov 13, 2019 6:30 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: [5.70] HTTPRequest and InitNetwork
PostPosted: Thu May 23, 2019 2:12 pm 
Offline
Addict
Addict
User avatar

Joined: Tue Dec 23, 2003 3:54 am
Posts: 1671
The help for HTTPRequest() says
Quote:
InitNetwork() has to be called before using this command.


but that doesn't seem to be true (Windows 10, PB 5.70 x86)
Code:
;InitNetwork()

HttpRequest = HTTPRequest(#PB_HTTP_Get, "https://www.google.com")
If HttpRequest
  Debug "StatusCode: " + HTTPInfo(HTTPRequest, #PB_HTTP_StatusCode)
  Debug "Response: " + HTTPInfo(HTTPRequest, #PB_HTTP_Response)
 
  FinishHTTP(HTTPRequest)
Else
  Debug "Request creation failed"
EndIf

_________________
On GitHub: PB Includes - IDE Tools - Color Themes


Top
 Profile  
Reply with quote  
 Post subject: Re: [5.70] HTTPRequest and InitNetwork
PostPosted: Thu May 23, 2019 2:33 pm 
Online
Enthusiast
Enthusiast

Joined: Thu Dec 29, 2011 5:03 pm
Posts: 500
Same on macOS (Mojave - 10.14.4, PB 5.71b1 x64).


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

 


Powered by phpBB © 2008 phpBB Group
subSilver+ theme by Canver Software, sponsor Sanal Modifiye