[Done] PB 6.03 LTS wont start...

Post bugreports for the Mac OSX version here
Joris
Addict
Addict
Posts: 885
Joined: Fri Oct 16, 2009 10:12 am
Location: BE

Re: PB 6.03 LTS wont start...

Post by Joris »

mk-soft have you seen the video's on "how to install a newer OS version with OpenCore Legacy Patcher" ?
To me that way looks doable... if I can get the Sonoma os first.
Yeah I know, but keep in mind ... Leonardo da Vinci was also an autodidact.
Fred
Administrator
Administrator
Posts: 16451
Joined: Fri May 17, 2002 4:39 pm
Location: France
Contact:

Re: PB 6.03 LTS wont start...

Post by Fred »

OpenCore automatically download the desired OS version IIRC
Joris
Addict
Addict
Posts: 885
Joined: Fri Oct 16, 2009 10:12 am
Location: BE

Re: PB 6.03 LTS wont start...

Post by Joris »

Okey, I saw that in those videos, but my connection is not that good, and that's why I thought, I would try to have Sonoma on SSD in advance
which also appears to be possible when using OpenCore.
What means IIRC ?

Thanks.
Yeah I know, but keep in mind ... Leonardo da Vinci was also an autodidact.
Bmld756
User
User
Posts: 14
Joined: Mon Sep 19, 2022 3:30 pm

Re: PB 6.03 LTS wont start...

Post by Bmld756 »

Hello,


I confirm, OCPl is a very good solution to update an (old) Mac and very simple to use. I use PB 6.03 on Mac 2012 / OCLP with Ventura without issue. I install Sonoma with OCPL and it is impossible de compile a simple PB source. I test an other compiler and the result is the same.

I test PB6 on my M1/sonoma correctly, so it is a OCPL problem, but very difficult to find information to found why.

Do you use PB6 on Mac/ocpl/sonoma ?

have a god day.
IMAC 21.5 2012 Core I5 - 2.70 Ghz. 16 GB NVIDIA GeForce GT 640M 512 Mo. MacOs OCPL Sonoma 14.1.
MacBook Air M1 - 8Go - Sonoma 14.1

PureBasic 6.03 (MacOS X - x64)
Joris
Addict
Addict
Posts: 885
Joined: Fri Oct 16, 2009 10:12 am
Location: BE

Re: PB 6.03 LTS wont start...

Post by Joris »

At one point I received Error messages when closing PB. I hoped this would be over with PB6.03. So no. I don't know what exactly causes the problems. I discovered that OpenCore Upgrade and thought I would try it. But if I understand you correctly, that wouldn't solve the problems. So it might be better to first try out the other solution that mk-soft and Fred provide. A bit of a difficult decision because I would also have liked to install other software from the store, but it doesn't work on Big Sur...
Yeah I know, but keep in mind ... Leonardo da Vinci was also an autodidact.
Joris
Addict
Addict
Posts: 885
Joined: Fri Oct 16, 2009 10:12 am
Location: BE

Re: PB 6.03 LTS wont start...

Post by Joris »

My problems are solved (for me now) I installed the previous version of PB6.02.
Yeah I know, but keep in mind ... Leonardo da Vinci was also an autodidact.
Bmld756
User
User
Posts: 14
Joined: Mon Sep 19, 2022 3:30 pm

Re: PB 6.03 LTS wont start...

Post by Bmld756 »

hello

I test 6,02,6.01 ,6.0 and I have an error when I compile. I Test with the oldest version of Ventura 13.5 and allways the same problem I have a version 13.1 and PB work correctly but this OS is on SSD with problem. So if I don't find 13.1 I will install Monterey to use PB ! on my new SSD.
IMAC 21.5 2012 Core I5 - 2.70 Ghz. 16 GB NVIDIA GeForce GT 640M 512 Mo. MacOs OCPL Sonoma 14.1.
MacBook Air M1 - 8Go - Sonoma 14.1

PureBasic 6.03 (MacOS X - x64)
Bmld756
User
User
Posts: 14
Joined: Mon Sep 19, 2022 3:30 pm

Re: PB 6.03 LTS wont start...

Post by Bmld756 »

Hello

I installe a new Ventura 13.0 with pb 6.03 and it work :D . Information : Ventura 13.3.1 introduce Rapid Security Response , perhaps it is the pb because impossible to compile with a 13.5.
IMAC 21.5 2012 Core I5 - 2.70 Ghz. 16 GB NVIDIA GeForce GT 640M 512 Mo. MacOs OCPL Sonoma 14.1.
MacBook Air M1 - 8Go - Sonoma 14.1

PureBasic 6.03 (MacOS X - x64)
Bmld756
User
User
Posts: 14
Joined: Mon Sep 19, 2022 3:30 pm

Re: PB 6.03 LTS wont start...

Post by Bmld756 »

Hello,

PB 6,03 works fine on Sonoma with OCPL.

I test Sonoma and PB with the commande line tools so It was impossible to compil. I tested to install Xcode and then PB6,03 works correctly.
Last edited by Bmld756 on Sun Dec 03, 2023 8:44 pm, edited 1 time in total.
IMAC 21.5 2012 Core I5 - 2.70 Ghz. 16 GB NVIDIA GeForce GT 640M 512 Mo. MacOs OCPL Sonoma 14.1.
MacBook Air M1 - 8Go - Sonoma 14.1

PureBasic 6.03 (MacOS X - x64)
Joris
Addict
Addict
Posts: 885
Joined: Fri Oct 16, 2009 10:12 am
Location: BE

Re: PB 6.03 LTS wont start...

Post by Joris »

Ok. That's good news.
Thanks
Yeah I know, but keep in mind ... Leonardo da Vinci was also an autodidact.
Fred
Administrator
Administrator
Posts: 16451
Joined: Fri May 17, 2002 4:39 pm
Location: France
Contact:

Re: PB 6.03 LTS wont start...

Post by Fred »

Fixed.
Joris
Addict
Addict
Posts: 885
Joined: Fri Oct 16, 2009 10:12 am
Location: BE

Re: [Done] PB 6.03 LTS wont start...

Post by Joris »

Thanks.
Yeah I know, but keep in mind ... Leonardo da Vinci was also an autodidact.
Bmld756
User
User
Posts: 14
Joined: Mon Sep 19, 2022 3:30 pm

Re: [Done] PB 6.03 LTS wont start...

Post by Bmld756 »

Thank
IMAC 21.5 2012 Core I5 - 2.70 Ghz. 16 GB NVIDIA GeForce GT 640M 512 Mo. MacOs OCPL Sonoma 14.1.
MacBook Air M1 - 8Go - Sonoma 14.1

PureBasic 6.03 (MacOS X - x64)
User avatar
Piero
Enthusiast
Enthusiast
Posts: 275
Joined: Sat Apr 29, 2023 6:04 pm
Location: Italy

Re: PB 6.03 LTS wont start...

Post by Piero »

Fred wrote: Fri Nov 24, 2023 4:03 pm What I can suggest is to install a newer OS version with OpenCore Legacy Patcher: https://dortania.github.io/OpenCore-Legacy-Patcher/

I put MacOS 13 on my old Macbook air mid-2012 and it works perfectly. It's really easy to do as well.
I MUST say it again Fred: THANKS!
Not just for me (I have some old Macs…)

That will allow talented PB developers with a low budget to PB stuff on Mac!!!
Post Reply