[Solved] Ubuntu : 3D examples /usr/bin/ld:cannot find -IGL

Linux specific forum
User avatar
Comtois
Addict
Addict
Posts: 1420
Joined: Tue Aug 19, 2003 11:36 am
Location: Doubs - France

[Solved] Ubuntu : 3D examples /usr/bin/ld:cannot find -IGL

Post by Comtois »

PB work fine with gadget or Sprite examples, camera.pb has worked fine, but particle.pb wasn't ok , so i changed my graphic card driver : Nvidia 173 to Nvidia 177(the last one).

Now i get this message with 3D examples :
/usr/bin/ld:cannot find -IGL
collect2:ld a envoyé xxxx
I tried to come back with my driver, but now 3D examples doesn't work anymore and i get the same message :
/usr/bin/ld:cannot find -IGL
collect2:ld a envoyé xxxx
I'm new to linux, and i don't know where to start to solve this ?
Please correct my english
http://purebasic.developpez.com/
dawlane
New User
New User
Posts: 1
Joined: Tue Nov 04, 2008 10:32 pm

Post by dawlane »

Hi Comtois

The error /usr/bin/ld:cannot find -IGL means that there is a problem locating the openGL libs thats found in the /usr/lib directory. These files (libGL.so/libGL.so.1) are actually symbolic links to the latest version of libGL (currently libGL.so.1.2 on my machine and also found in /usr/lib).

Sound like that the nVidia driver has messed these up in some way. Check and see if they are there and that they are linked to the correct file. If they are not there and the latest libGL file is there or the links target is wrong then delete and create some new links by right clicking the latest libGL file and renaming them (NOTE you need to be sudo to do this to get the file browser in this mode pres Alt+F2 and type: gksudo nautilus /usr/lib.)
NOTE BE WARNED BEING SUDO (also known as root/super user/god) CAN BE VERY DANGEROUS AND CAN MESS YOUR SYSTEM UP IN A BAD WAY.

You could try and re-install the package libgl1-mess-glx, check that the files are there then re-install the nVidia driver and check again.
User avatar
Comtois
Addict
Addict
Posts: 1420
Joined: Tue Aug 19, 2003 11:36 am
Location: Doubs - France

Post by Comtois »

Hi dawlane,


I also asked on a french forum and somebody suggested me to reinstall opengl
sudo apt-get install --reinstall libgl1-mesa-glx
As it still does not work, I reinstalled ubuntu.
And I changed the driver before installing PureBasic now everything works.

Thank you for your help, I understand better the message now. And it will help me for the next driver update:)
Please correct my english
http://purebasic.developpez.com/
Post Reply