Aktuelle Zeit: 05.07.2020 17:37

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 5 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Problem mit Findstring
BeitragVerfasst: 26.10.2019 21:08 
Offline

Registriert: 06.03.2019 21:52
Tach allerseits!

Habe folgendes Problem: Die beiden Codezeilen
Zitat:
Debug FindString("Suppenkasper","Kasper",#PB_String_NoCase)
Debug FindString("Suppenkasper","Kasper")


sollten eigentlich 2 verschiedene Ergebnisse haben, Debug gibt jedoch für beide "0" aus.
Ist das ein Denkfehler von mir?

_________________
Der beste Fisch ist der Schnitzel


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Problem mit Findstring
BeitragVerfasst: 26.10.2019 21:27 
Offline

Registriert: 27.11.2016 18:13
Wohnort: Erzgebirge
Ein freundliches Hallo an "bin_neu_hier".

bin_neu_hier hat geschrieben:
Habe folgendes Problem: Die beiden Codezeilen
Zitat:
Debug FindString("Suppenkasper","Kasper",#PB_String_NoCase)
Debug FindString("Suppenkasper","Kasper")


sollten eigentlich 2 verschiedene Ergebnisse haben, Debug gibt jedoch für beide "0" aus.
Ist das ein Denkfehler von mir?


Oha!

Ich sehe das irgendwie auch als BUG.

Seltsam?

Workaround:

Code:
Debug FindString(LCase("Suppenkasper"), LCase("Kasper"))
Debug FindString("Suppenkasper", "Kasper")

_________________
Betriebssysteme: MX Linux 19 / Windows 10 / Mac OS 10.15.2 / Android 7.0 ;)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Problem mit Findstring
BeitragVerfasst: 26.10.2019 21:34 
Offline

Registriert: 06.03.2019 21:52
Hallo ccode_new!

Ja, cool, hatte 'ne Weile gebraucht, um das Problem überhaupt zu finden, weil ich ja immer erstmal davon ausgehe, dass ich irgendeinen Fehler verursacht habe (ist ja auch meistens so ...). Werde im Vergleich ein Lcase den Strings voransetzen, das müsste für meine Zwecke genügen. Wer einen Draht zu den PB-Schöpfern hat, kann ja mal einen Verbesserungsvorschlag unterbreiten.

Servus!

_________________
Der beste Fisch ist der Schnitzel


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Problem mit Findstring
BeitragVerfasst: 26.10.2019 21:45 
Offline

Registriert: 27.11.2016 18:13
Wohnort: Erzgebirge
Ach ich bin Doof!

Das mir das passiert!

Nun Klartext:

Wir haben jetzt BEIDE die Parameteranzahl missachtet.

FindString(String$, StringToFind$ [, StartPosition [, Mode]])

Beim genauen Nachzählen ist uns beiden ein Denkfehler unterlaufen.

Ja an welcher Stelle steht den die StartPosition und wo Mode ?

_________________
Betriebssysteme: MX Linux 19 / Windows 10 / Mac OS 10.15.2 / Android 7.0 ;)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Gelöst: Problem mit Findstring
BeitragVerfasst: 26.10.2019 21:54 
Offline

Registriert: 06.03.2019 21:52
Hi!

Na da ist ja die Welt wieder in Ordnung. Ich war also doch schuld am Fehler, wie hätte es auch anders sein können.

Danke für die Erleuchtung!

_________________
Der beste Fisch ist der Schnitzel


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 5 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 9 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  

 


Powered by phpBB © 2008 phpBB Group | Deutsche Übersetzung durch phpBB.de
subSilver+ theme by Canver Software, sponsor Sanal Modifiye