Mail Versand per SMTP-Server

Anfängerfragen zum Programmieren mit PureBasic.
Benutzeravatar
Velindos
Beiträge: 566
Registriert: 15.11.2010 10:56

Re: Mail Versand per SMTP-Server

Beitrag von Velindos »

Hallo Leute!

Danke für die Tips! Nun läuft die Sache tatsächlich mit Port 465, Danke!

Der Text und das Bild funzen!

Da ich mein Stichwort als Betreff übertragen möchte, habe ich den Text aus dem Stringgadget mittel´s Getgadgettext ausgelesen und dieser zeigt aber dann keine Sonderzeichen im Mail Betreff! Obwohl im Debugger der Text ordentlich angezeigt wird!

Nun habe ich es mit der unten angehängeten Routine versucht und es geht auch nicht, immer Wirwar!

Code: Alles auswählen

Macro Unicode(Mem, Type = #PB_Ascii)
  PeekS(Mem, -1, Type)
EndMacro

*MailTo_Stichwort = Ascii("Test - éàîöÊÜöÜÖÄÄ")
; *MailTo_Stichwort = UTF8("Test - éàîöÊÜöÜÖÄÄ")
Debug  Unicode(*MailTo_Stichwort)
Debug  Unicode(*MailTo_Stichwort, #PB_Ascii)
Jemand noch einen Tip?

Gruss ... Velindos!
Windows 7/8/8.1/10 (32/64-Bit) |Ubuntu 10.4 (64-Bit) |Purebasic 5.71 LTS (32/64-Bit)
Benutzeravatar
HeX0R
Beiträge: 2804
Registriert: 10.09.2004 09:59
Computerausstattung: AMD Ryzen 7 5800X
2x16Gig Ram
NVIDIA GEFORCE GTX 1060/6Gig
Win10 64Bit
G19 Tastatur
2x 24" + 1x27" Monitore
Glorious O Wireless Maus
PB 3.x-PB 6.x
Oculus Quest 2
Kontaktdaten:

Re: Mail Versand per SMTP-Server

Beitrag von HeX0R »

Kann ich ebenfalls nicht bestätigen, Umlaute im Betreff funktionieren einwandfrei (ohne sinnloses Gemurkse)
Benutzeravatar
Velindos
Beiträge: 566
Registriert: 15.11.2010 10:56

Re: Mail Versand per SMTP-Server

Beitrag von Velindos »

Hallo,

wenn im Stichowrt-Text "TÖRN of 2021" ist und die Sache mit
MailTo_Betreff$ = GetGadgetText(Work_S_Stichwort)
lese und ans Betreff übergebe erhalte ich ein mit mit folgenden TEXT:
Meine {üäö€} Zeichen
Also keine Fiktion!

Gruss ... Velindos!
Windows 7/8/8.1/10 (32/64-Bit) |Ubuntu 10.4 (64-Bit) |Purebasic 5.71 LTS (32/64-Bit)
Benutzeravatar
HeX0R
Beiträge: 2804
Registriert: 10.09.2004 09:59
Computerausstattung: AMD Ryzen 7 5800X
2x16Gig Ram
NVIDIA GEFORCE GTX 1060/6Gig
Win10 64Bit
G19 Tastatur
2x 24" + 1x27" Monitore
Glorious O Wireless Maus
PB 3.x-PB 6.x
Oculus Quest 2
Kontaktdaten:

Re: Mail Versand per SMTP-Server

Beitrag von HeX0R »

Mail per PB verschickt und wie folgt in Thunderbird angekommen:
Bild
Aber egal, ich bin jetzt raus.
Benutzeravatar
Velindos
Beiträge: 566
Registriert: 15.11.2010 10:56

Re: Mail Versand per SMTP-Server

Beitrag von Velindos »

Hallo HeX0R,

Fehler gefunden => #PB_Ascii muss eingetragen sein!
If CreateMail(0, Benutzer$, "Hello", #PB_Ascii)

Danke noch für deine Unterstützung und einen schönen Sonntag!

Gruss ... Velindos!
Windows 7/8/8.1/10 (32/64-Bit) |Ubuntu 10.4 (64-Bit) |Purebasic 5.71 LTS (32/64-Bit)
Antworten