Aktuelle Zeit: 16.08.2017 15:11

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Linkfehler nach Update von 5.24 auf 5.44
BeitragVerfasst: 22.07.2017 17:39 
Offline

Registriert: 06.06.2013 20:37
Hallo zusammen,

nach dem ich ein kleines Prog. unter Windows mit V5.60 geschrieben habe wollte ich es auch unter Linux compilieren lassen wo aktuell 5.24 installiert ist. Mit Linux hatte ich lange nichts mehr gemacht.
Unter 5.24 bekomme ich keinen Linkfehler aber da ich das webview verwende kann das mit der 5.24 nicht durchlaufen.
Also zunächst die Linuxversion mit 5.60 versucht was den gleichen Linkfehler bringt wie die 5.44 die ich jetzt getestet habe.
Die Meldung die kommt ist:
-------------------------------
PuseBasic - Linker error
Gadget.a(TextGadget.o):in function `SetGadgetColor´;
Textgadget.c:(.text+0x8): undefined referenc to
`gtk_widget_get_type´

dann noch mehrere Zeilen in dieser Art
-------------------------------
Zusätzlich zum 5.24 ist devx installiert

Woran kann es liegen?

LG

Wolfgang

_________________
Satellite A210-19Z, Samsung N130, VPAD10, WinXP, Win7, PuppyLinux, PB 5.24, 5.31
Elektronik, Mikrocontroller, CNC-Technik, 3D-Druck


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linkfehler nach Update von 5.24 auf 5.44
BeitragVerfasst: 22.07.2017 18:46 
Offline
Benutzeravatar

Registriert: 08.09.2004 00:57
Wohnort: Berlin
derschutzhund hat geschrieben:
Unter 5.24 bekomme ich keinen Linkfehler aber da ich das webview verwende kann das mit der 5.24 nicht durchlaufen.

Was soll das sein, webview?
derschutzhund hat geschrieben:
Also zunächst die Linuxversion mit 5.60 versucht was den gleichen Linkfehler bringt wie die 5.44 die ich jetzt getestet habe.

Wäre jetzt noch Interessant, welche Linuxversion (Distribution).

derschutzhund hat geschrieben:
Die Meldung die kommt ist:
-------------------------------
PuseBasic - Linker error
Gadget.a(TextGadget.o):in function `SetGadgetColor´;
Textgadget.c:(.text+0x8): undefined referenc to
`gtk_widget_get_type´

dann noch mehrere Zeilen in dieser Art

checkinstall.sh gestartet und was sagt es?
derschutzhund hat geschrieben:
Zusätzlich zum 5.24 ist devx installiert

Was ist das?

Check erstmal, ob Deine PB Version korrekt, mit allen Abhängigkeiten installiert wurde. Dafür sind hier mehrere Beiträge
vorhanden, so das eine Wiederholung denke ich mal nicht nötig ist.

Wenn der Fehler nicht verschwindet, dann bitte eine korrekte Fehlermeldung, als mit Distribution, Version usw.
sonst kann man Dir nur durch raten helfen, was nur das Forum vollmüllen würde.

Gruß
Thomas

_________________
PureBasic 5.60 | SpiderBasic 2.10 | Windows 10 Pro (x64) | Linux Mint 18.2 (x64)
"Ich möchte gerne die Welt verändern, doch Gott gibt den Quellcode nicht frei."
Bild


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linkfehler nach Update von 5.24 auf 5.44
BeitragVerfasst: 23.07.2017 22:23 
Offline

Registriert: 06.06.2013 20:37
Zitat:
Was soll das sein, webview?

webgadget!

Zitat:
Wäre jetzt noch Interessant, welche Linuxversion (Distribution).

Puppy Linux, basiert auf Tahr6.02 -> Ubuntu 14.04 LTS Trusty Tahr

Zitat:
checkinstall.sh gestartet und was sagt es?

Hatte ich bisher nicht gemacht!
Mir ist dabei aufgefallen, dass das Webgadget bereits mit der Version 5.24 nicht richtig arbeitet.
Es sieht so aus als ob es ein Problem mit einer fehlenden gtk-lib wäre.

Zitat:
Was ist das?

In Puppylinux befinden sich einige Systemlibs in einer Datei die Defx.sfs heißt.

Vermutlich ist Puppy so etwas Besonderes, dass ich vermutlich mehr Infos dazu im Puppyforum bekommen werde.

LG

Wolfgang

_________________
Satellite A210-19Z, Samsung N130, VPAD10, WinXP, Win7, PuppyLinux, PB 5.24, 5.31
Elektronik, Mikrocontroller, CNC-Technik, 3D-Druck


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linkfehler nach Update von 5.24 auf 5.44
BeitragVerfasst: 23.07.2017 23:45 
Offline
Benutzeravatar

Registriert: 08.09.2004 00:57
Wohnort: Berlin
Abhängigkeiten findest Du hier: viewtopic.php?p=341396#p341396

WebGadget sollte dann auch fehlerfrei laufen:
sudo apt-get install libwebkitgtk-dev libwebkitgtk-3.0-dev libwebkit2gtk-4.0-dev

Solange man checkinstall.sh nutzen kann (nur deb) sollte man dies auch unbedingt tun!

Es reicht also nicht, PB einfach entpacken und Desktopverknüpfung. Das reicht vielleicht das die IDE läuft, aber kompilieren
läßt sich erstmal noch nichts. Man sollte sich also erstmal ein wenig Zeit nehmen und dann im PB Ordner die Dateien, sowie in den
Foren, alles erstmal ausführen (setup, install, readme usw.).

Wenn man das erstmal gescheckt hat, läuft jede weitere Installation schon weitgehend automatisch ab.

_________________
PureBasic 5.60 | SpiderBasic 2.10 | Windows 10 Pro (x64) | Linux Mint 18.2 (x64)
"Ich möchte gerne die Welt verändern, doch Gott gibt den Quellcode nicht frei."
Bild


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  

 


Powered by phpBB © 2008 phpBB Group | Deutsche Übersetzung durch phpBB.de
subSilver+ theme by Canver Software, sponsor Sanal Modifiye