PureBoard
http://forums.purebasic.com/german/

Linux gibt Port nicht frei
http://forums.purebasic.com/german/viewtopic.php?f=21&t=32056
Seite 1 von 1

Autor:  stevie1401 [ 29.07.2020 20:03 ]
Betreff des Beitrags:  Linux gibt Port nicht frei

Ich arbeite mit mehreren Purebasic TCP und Websockets-Server-Programmen.
Wenn diese unter Linux (Ubuntu und Debian) in der Purebasic IDE laufen und ich breche das Server-Programm im laufenden Betrieb ab, dann lässt sich dieses Programm nur sehr schwer wieder neu starten.
Manchmal funktioniert es nach mehreren Versuchen innerhalb von 5 Minuten, manchmal muss ich sogar Linux neu starten, damit das Serverprogramm sich neu starten läßt.
"Schuld" daran wird, so vermute ich zumindest, ein nicht wieder freigegebener Port sein.
Starte ich das abgebrochene Serverprogramm mit einem anderen Port, funktioniert es sofort.
Hat jemand eine Idee wie man das beheben kann?
Das passiert übrigens auch, wenn ich das Serverprogramm ordnungsgemäß beende.

Ein WebSocket_Server::Free(*Server) beim Web-Socket-Serverprogramm hilft leider nichts.

Unter Windows funktioniert alles problemlos.
Hat jemand eine Idee?

Autor:  NicTheQuick [ 29.07.2020 20:33 ]
Betreff des Beitrags:  Re: Linux gibt Port nicht frei

Genau das gleiche Thema hatten wir schon mal mit verschiedenen Lösungsversuchen von mir: Webserver bzw. Problem mit SendNetworkData()
Ich hatte hier dann eine Lösung dazu. Das schien zuerst doch, dann doch nicht mehr funktioniert zu haben. Aber dann bin ich wohl ausgestiegen aus dem Thread. Ups :mrgreen:

Probier das doch trotzdem mal aus.

Autor:  stevie1401 [ 29.07.2020 21:53 ]
Betreff des Beitrags:  Re: Linux gibt Port nicht frei

Besten Dank für die Info!
Das schaue ich mir gleich einmal an.

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/