Aktuelle Zeit: 12.12.2017 23:58

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Darstellungsproblem in der IDE unter macOS 10.13
BeitragVerfasst: 10.10.2017 07:32 
Offline

Registriert: 14.08.2014 14:32
Hallo zusammen,

wahrscheinlich in Verbindung macOS 10.13 habe ich noch ein weiteres Problem.

Ich öffne in der IDE mein Projekt und damit auch gleichzeitig das zugehörige
Hauptprogramm (*.pb). Es funktioniert alle einwandfrei. Editor geht, das Wechseln
zwischen beiden Registern. Perfekt!

Nun öffne ich eine der Formulare (*.pbf). Soweit auch noch ok. Ich kann im Formular
sowohl im Quellcode editieren als auch im Designer arbeiten.

Wechsle ich ich nun zu meinem Hauptprogramm (*.pb), wird der Editor-Bereich nicht
restauriert und auch nicht der Editor dargestellt. Editieren könnte ich zwar, die
Kursorposition wird unten auch aktualisiert.

Selbst bei Dialogen aus der IDE wie Voreinstellungen, Speichern, ... wird der Bildschirm
nicht mehr restauriert.

Wechsle ich zurück in das Formular (*.pbf) oder Projekt, funktioniert wieder alles.

Wie erwähnt habe ich macOS 10.13 vom 05.10.2017, wobei das Update vom 05.10.
nichts geändert hat sowie PB 5.61 x64.

Jemand eine Idee?

_________________
MacBook Pro (13-inch, Mid 2012, I7 2.9GHz, 8GB), OSX 10.10, PB 5.31 x64 - VmWare-Fusion: Win7 Home Premium, XP Professional, Ubuntu 14.04 - ZX81 - Apple II - Atari ST


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Darstellungsproblem in der IDE unter macOS 10.13
BeitragVerfasst: Gestern 18:29 
Offline

Registriert: 14.08.2014 14:32
Hallo,

leider kämpfe ich immer noch mit meinem Problem.

Allerdings kann ich es nun etwas besser beschreiben bzw. habe eine Möglichkeit gefunden dass es nicht auftritt :)

Ich arbeite nach wie vor mit PureBasic 5.61 x64 unter MacOS 10.13.1

Ich öffne in der IDE mein Projekt (Reiter 1), dann einen Quell-Code (Reiter 2) und noch einige Formulare (Reiter 3-5)

Soweit passt alles. Klicke ich auf Reiter 1 oder 3-5, wird der Fensterinhalt zuverlässig angezeigt. Klicke ich jedoch auf Reiter 2,
bleibt der Fensterinhalt des letzten Reiters bestehen. Die Titelzeile und sogar Zeile und Spalten-Zähler werden aber aktualisiert.
Selbst bei einem Screen-Shot (Cmd-Shift-4) , gibt es Probleme im Bereich des Fensters, in der Form dass es im Screen-Shot
ohne Inhalt zu sehen ist.


Hier Kick auf Reiter 1:
Bild

Hier Kick auf Reiter 2:
Bild

Hier Kick auf Reiter 3:
Bild



Achtung, schließe ich nun alle Fenster bis auf mein Projekt, wird automatisch des NEU-Register eingefügt. Das könnte die
Lösung für diesen Bug sein!! Anschließend öffne ich wieder meine PB-Datei und PBF-Dateien, ab jetzt kann ich Register mit
der PB-Datei - nun Register 3 - wie gewohnt anklicken.



Hier Kick auf Reiter 1:
Bild

Hier Kick auf Reiter 2:
Bild

Hier Kick auf Reiter 3:
Bild

Hier Kick auf Reiter 4:
Bild


Möglicherweise hat nun jemand eine Idee mit der IDE


Best Grüße

_________________
MacBook Pro (13-inch, Mid 2012, I7 2.9GHz, 8GB), OSX 10.10, PB 5.31 x64 - VmWare-Fusion: Win7 Home Premium, XP Professional, Ubuntu 14.04 - ZX81 - Apple II - Atari ST


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Darstellungsproblem in der IDE unter macOS 10.13
BeitragVerfasst: Gestern 19:16 
Offline

Registriert: 26.11.2017 16:17
Bei den Einstellungen gibt es unter 'Editor' eine Checkbox für dieses 'Neu-Register'. Vielleicht hilft es wenn du sie aktivierst.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Darstellungsproblem in der IDE unter macOS 10.13
BeitragVerfasst: Gestern 22:31 
Offline
Benutzeravatar

Registriert: 24.11.2004 13:12
Wohnort: Germany
Habe das gleiche Problem nach den Update auf macOS 10.13.1

Hat nichts geholfen...
Liegt irgend am ScintillaGadget

_________________
Alles ist möglich, fragt sich nur wie...
Projekte EventDesigner v1.x / OOP-BaseClass-Modul / OPC-Helper DLL
PB v3.30 / v5.4x - OS Mac Mini OSX 10.xx / Window 10 Pro. (X64) /Window 7 Pro. (X64) / Window XP Pro. (X86) / Ubuntu 14.04
Downloads auf Webspace


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  

 


Powered by phpBB © 2008 phpBB Group | Deutsche Übersetzung durch phpBB.de
subSilver+ theme by Canver Software, sponsor Sanal Modifiye