Aktuelle Zeit: 18.06.2018 13:27

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 19.09.2014 14:35 
Offline
Benutzeravatar

Registriert: 15.10.2013 14:20
Seit ich auf Mavericks Version 10.9.5 upgedatet habe und mir dabei scheinbar Xcode 6.0.1 inklusive der Comman Line Tools (OS 10.9) geholt habe, kann ich kein Programm mehr linken bzw. erhalte stets einen linker error. Kann mir jemand bitte helfen um diesen Fehler zu beseitigen?

Vielen Dank im Voraus...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 19.09.2014 20:22 
Offline
-= Anfänger =-
Benutzeravatar

Registriert: 29.08.2004 03:07
Habe es mal ins englische Forum weiter gereicht: Xcode 6.x support?
Xcode 6.0.1 wurde erst gestern offiziell veröffentlicht, also muss PB erst daran angepasst werden.

Vielleicht möchtest Du in der Zwischenzeit Xcode 5.1.1 und dessen Commandline Tools verwenden.
Findest Du in den Developer Downloads. Musst Dich nur mit Deiner normalen Apple ID anmelden.

_________________
cya,
...Danilo
"Ein Genie besteht zu 10% aus Inspiration und zu 90% aus Transpiration" - Max Planck


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 20.09.2014 03:45 
Offline
Benutzeravatar

Registriert: 15.10.2013 14:20
Danke Dir, habe bis jetzt auch XCode 5 genutzt und voreilig upgedatet. Aber das ist ja Gott sei Dank rückgängig zu machen... (hoffe ich).

Habe es jetzt wieder am Laufen: PB 5.30 -10.9.5 - XCode 5.1.1 aber mit den aktuellen CTools die mir beim update auf 10.9.5 draufgespielt wurden.

Klappt wieder, und falls demnächst eine Anpasssung wegen XCode 6 erscheint, tausche ich zurück.

Nochmals danke,
pi^2

:)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 21.09.2014 20:57 
Offline
Benutzeravatar

Registriert: 12.09.2004 03:31
Wohnort: North by Northwest
Als OS habe ich auch OSX Mavericks und benutze ebenfalls das neueste Xcode.
Compilieren und linken funktioniert einwandfrei.

Allerdings benutze ich ja die englische Version.
Unter Preferences->Locations kann man die installierte Command Line Tools version sehen.
Bei mir ist es die Version Xcode 6.0.1 (6A317).

Dafuer haengt manchmal die PB-IDE wenn ich eine Datei schliessen will.

Irgendwas ist ja immer...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 22.09.2014 00:40 
Offline
Benutzeravatar

Registriert: 15.10.2013 14:20
@fsw: Leider finde ich die von Dir erwähnten Hinweise über die verwendeten tools nirgends. Wo in 'preferences' ist denn 'locations'? Ich benutze PB 5.30.

Danke!

pi2


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 22.09.2014 03:44 
Offline
Benutzeravatar

Registriert: 12.09.2004 03:31
Wohnort: North by Northwest
piquadrat hat geschrieben:
@fsw: Leider finde ich die von Dir erwähnten Hinweise über die verwendeten tools nirgends. Wo in 'preferences' ist denn 'locations'? Ich benutze PB 5.30.

Nicht die "preferences" in der PB IDE, sondern Xcode IDE.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 22.09.2014 07:23 
Offline
-= Anfänger =-
Benutzeravatar

Registriert: 29.08.2004 03:07
Habe nun auch das Update auf Xcode 6.0.1 gemacht - ohne Probleme.

Direkt nach dem Update zeigte PureBasic folgenden Fehler:
Bild
Einfach einmal Xcode selbst starten (um der Lizenz zuzustimmen und um ein paar Komponenten nachzuladen),
und danach funktionierte auch PB wieder.

_________________
cya,
...Danilo
"Ein Genie besteht zu 10% aus Inspiration und zu 90% aus Transpiration" - Max Planck


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 22.09.2014 16:21 
Offline
Benutzeravatar

Registriert: 15.10.2013 14:20
@Danilo: SUPER! Ich stand wirklich auf der Leitung - habe den 'error-Text' gar nicht richtig gelesen. Nachdem ich XCode 6.0.1 gestartet habe wurden weitere Komponenten nachgeladen. Zudem musste ich einfach zustimmen! Jtzt geht alles wieder wie gewünscht.

Vielen Dank für Eure schnelle und gute Hilfe!

pi2 ... :allright:


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Linker error seit OS 10.9.5 und XCode 6.0.1
BeitragVerfasst: 25.09.2014 09:50 
Offline

Registriert: 04.12.2008 10:50
Wohnort: Essen
Vielen Dank, hat auch mir geholfen........


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  

 


Powered by phpBB © 2008 phpBB Group | Deutsche Übersetzung durch phpBB.de
subSilver+ theme by Canver Software, sponsor Sanal Modifiye