MySQL 8

Für allgemeine Fragen zur Programmierung mit PureBasic.
Benutzeravatar
techniker
Beiträge: 138
Registriert: 27.01.2016 11:08
Wohnort: BY

MySQL 8

Beitrag von techniker »

Hallo,

hat hier schon jemand eine Verbindung zu MySQL 8.0.26 erfolgreich aufbauen können?
(Also dem "echten" neuen MySQL8 mit SSL-Verschlüsselung und nicht den "Legacy"-Modus..)

Hat hier jemand ein Beispiel für mich? :mrgreen:

Danke!
Never change a running system - Never run a changed system!
(PB 5.62 [x86] und PB 5.71 [x86])
MenschMarkus
Beiträge: 197
Registriert: 30.04.2009 21:21
Computerausstattung: i5-2300 (2.8 Ghz) Win10 -64bit / PB 7.3 LTS

Re: MySQL 8

Beitrag von MenschMarkus »

Schon mal via ODBC versucht?
Wissen schadet nur dem, der es nicht hat !
Benutzeravatar
techniker
Beiträge: 138
Registriert: 27.01.2016 11:08
Wohnort: BY

Re: MySQL 8

Beitrag von techniker »

Hi!

Die Anwendung soll auch weiterhin ohne ODBC mit dem Server kommunizieren.
Es gibt interne Gründe, warum dies explizit nicht gewünscht wird. Bitte nicht weiter hinterfragen.

Bisher wurde daher auch die libmysql.dll erfolgreich eingebunden und verwendet.

Trotzdem danke für den Vorschlag.
Never change a running system - Never run a changed system!
(PB 5.62 [x86] und PB 5.71 [x86])
MenschMarkus
Beiträge: 197
Registriert: 30.04.2009 21:21
Computerausstattung: i5-2300 (2.8 Ghz) Win10 -64bit / PB 7.3 LTS

Re: MySQL 8

Beitrag von MenschMarkus »

Ich sehe das Problem noch nicht. Wie bei ODBC gibst Du halt beim Öffnen der DB die notwendigen Daten ein statt beim Connector.

Code: Alles auswählen

OpenDatabase(0, "host=localhost port=3306 dbname=test", "user", "password")
Als host gebe ich z.B. die IP Adresse des SQL Servers ein und es funktioniert einwandfrei. Jedoch verwende ich keine SSL Verschlüsselung, da habe ich auch keine Erfahrung mit.
Wissen schadet nur dem, der es nicht hat !
Benutzeravatar
techniker
Beiträge: 138
Registriert: 27.01.2016 11:08
Wohnort: BY

Re: MySQL 8

Beitrag von techniker »

Dann verwendest du auch noch nicht MySQL8 oder hast den Legacy-Modus aktiviert. Genau das SSL mit der neuen Connector-DLL ist ja mein Problem!
Never change a running system - Never run a changed system!
(PB 5.62 [x86] und PB 5.71 [x86])
Antworten