PureBoard
http://forums.purebasic.com/german/

Bilder laden nur auf oberster Ebende
http://forums.purebasic.com/german/viewtopic.php?f=33&t=31297
Seite 1 von 1

Autor:  stevie1401 [ 10.02.2019 19:06 ]
Betreff des Beitrags:  Bilder laden nur auf oberster Ebende

Wenn ich programmiere, kann ich im SpiderEditor mit
Code:
 LoadImage(0,/bilder/pic1.jpg)



ein Bild laden.
Dabei ist der Ordner /bilder im Verzeichnes, in welchen im programmiere.
Z.B.: /home/stevie/proggen/meinneuesprogramm/bilder
Die sb-Datei ist in /home/stevie/proggen/meinneuesprogramm gespeichert.
/home/stevie/proggen/meinneuesprogramm/test.html

Nun kopiere ich den Ordner "meinneuesprogramm" samt Inhalt auf meine Homepage.

Nun rufe ich meine neue HTML Seite auf:
www.meineHomePage.de/meinneuesprogramm/test.html

Jetzt kann das Bild aber NICHT mehr von meineHomepage.de/meinneuesProgramm/bilder geladen weden.
Ich muss den Bilderordner auf die oberste Ebene legen:
www.meineHomePage.de/bilder
Nur von dort kann ich dann bilder laden.
Wie kann ich von Unterordnern Bilder laden?

Autor:  DarkDragon [ 10.02.2019 19:38 ]
Betreff des Beitrags:  Re: Bilder laden nur auf oberster Ebende

Slash am Anfang bedeutet Wurzelverzeichnis. Versuche es ohne diesen Slash:

Code:
LoadImage(0, "bilder/pic1.jpg")

Autor:  stevie1401 [ 10.02.2019 19:47 ]
Betreff des Beitrags:  Re: Bilder laden nur auf oberster Ebende

Perfekt!
Dankeschön :)

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/