Installation auf Raspberry PI 400

In dieser Linux-Ecke dürfen nur Themen rund um Linux geschrieben werden.
Beiträge, die plattformübergreifend sind, gehören ins 'Allgemein'-Forum.
Benubi
Beiträge: 157
Registriert: 22.10.2004 17:51
Wohnort: Berlin, Wedding

Installation auf Raspberry PI 400

Beitrag von Benubi »

Hallo!

Ich habe mir einen Raspberry 400 zu Weihnachten geschenkt. Anscheinend ist das Betriebssystem die Linux arm-32 Variante.

Obwohl ich alle Pakete installiert habe wie in der Anleitungsdatei beschrieben werden (copy & paste), gehen keine OpenGL/Screen Befehle.

Wenn ich die Beispiel-Dateien "WindowedScreen.pb", "OpenGLGadget.pb" und die Engine3D Beispiele ausführen möchte fehlen 2 Sachen:

Code: Alles auswählen

/usr/bin/ld cannot find -lGLU
/usr/bin/ld cannot find -lXxf86vm
collect2: error: ld returned 1 exit status
Benubi
Beiträge: 157
Registriert: 22.10.2004 17:51
Wohnort: Berlin, Wedding

Re: Installation auf Raspberry PI 400

Beitrag von Benubi »

Problem gelöst

Code: Alles auswählen

sudo apt install libglu-dev
sudo apt install libxxf86vm-dev
Groß und Kleinschreibung kann verwirren...
Benutzeravatar
mk-soft
Beiträge: 3554
Registriert: 24.11.2004 13:12
Wohnort: Germany

Re: Installation auf Raspberry PI 400

Beitrag von mk-soft »

Du kannst dir auch eine zusätzlich SD-Karte besorgen und auch die Arm64 installieren.
Sollte aber eine gute sein. Zum Beispiel ScanDisk Extreme V30 64GB

Habe ich gemacht.

Raspberry PI Imager Downloaden (z.B Window) von https://www.raspberrypi.com/software/
Image auswählen oder download von https://www.raspberrypi.com/software/operating-systems/


Frage:
Hast du auch installiert
Developer Libraries For Games
-----------------------------
sudo apt-get install libgl1-mesa-dev libgl1-mesa-glx
Sonst müsste ich die Install-Anleitung noch mal prüfen und aktualisieren.
Alles ist möglich, fragt sich nur wie...
Projekte ThreadToGUI / EventDesigner V3 / OOP-BaseClass-Modul
Downloads auf MyWebspace / OneDrive
Benubi
Beiträge: 157
Registriert: 22.10.2004 17:51
Wohnort: Berlin, Wedding

Re: Installation auf Raspberry PI 400

Beitrag von Benubi »

Ja, ich habe mir aber eine SD geholt, die "microSD kompatibel" ist - aber selbst keine microSD ist sondern nur eine normale SD :freak: :lol: :roll: xD. Zum Glück war die nicht teuer und ich kann das ja für ein anderes Projekt bei Seite legen.

Ich dachte mir möglicherweise zwei Partitionen auf der microSD anzulegen mit boot selection. Oder ist davon abzuraten? Vielleicht doch lieber eine microSD je OS?

Ansonsten wurschtel ich mit dem Debian rum. Irgendwie ist es nicht so einfach einen neuen User anzulegen mit dem man sich auch im Desktop einloggen kann. Das /etc/Skel Verzeichnis ist leer, ich trampel da auf der Stelle rum.

Ich habe es geschafft die .desktop Dateien so zu schreiben, daß PureBasic auch hüsch zwischen den anderen Links im "Programming" Startmenü steht :) Woran ich noch knabbere ist die Dateizuordnung, derzeit öffnet er nur geany wenn man auf .pb Dateien doppelklickt. Ich habe schon unter /etc/mime.types eine Zeile für PB Endungen hinzugefügt, aber es fehlt wohl noch ein Rädchen im Getriebe oder es ist nicht die richtige mime Datei welche LXDE benutzt (das soll wohl das Desktop management sein?).

Ich könnte Seiten an Fragen schreiben, die ich mir gerade stelle... :coderselixir:

Wie ist das mit den kompilierten PB Programmen, funktionieren die auch in den Pico's? Die Picos haben ja nur 256k RAM oder so, ich nehme an man könnte eh nur kleine "Konsolenprogramme" schreiben? Nun, ich habe ja nur sehr wenig Ahnung... Aber mit Pico würde ich auch genere basteln. Bis jetzt fehlt mir quasi alles zum Basteln (z.B. Breadboard und Lötstation) und vor Allem Ahnung. Elektrotechnik ist schon 20+ Jahre her bei mir. :)
Benutzeravatar
mk-soft
Beiträge: 3554
Registriert: 24.11.2004 13:12
Wohnort: Germany

Re: Installation auf Raspberry PI 400

Beitrag von mk-soft »

Siehe auch englische Forum. Da gibt es mehr ...

Raspberry PI
Tips & Tricks for Raspberry
Alles ist möglich, fragt sich nur wie...
Projekte ThreadToGUI / EventDesigner V3 / OOP-BaseClass-Modul
Downloads auf MyWebspace / OneDrive
Benubi
Beiträge: 157
Registriert: 22.10.2004 17:51
Wohnort: Berlin, Wedding

Re: Installation auf Raspberry PI 400

Beitrag von Benubi »

Danke für die Links!

Ich habe schon ein paar Erfolge errungen. Der Größte ist dass seit heute Morgen die Desktop-Auflösung korrekt gewählt wird, wenn der Monitor/Touchdisplay beim Booten ausgeschaltet bleibt (hier war nur 640x480 und nach dem booten mit verspätetem Einschalten blieb das Display schwarz). Jetzt geht das wie es sollte. Die externe USB Festplatte wird vor der Anmeldung ge-mountet.

Ich musste VLC neu installieren, damit die Menüs angezeigt werden. Man muss als Renderer OpenGL for embedded systems und den Monitorausgang (HDMI) explizit auswählen, dann wird VLC <20% der CPU benutzen (laut Befehl "top -i"). Wenn man das normale OpenGL auswählt, steigt die Belastung auch mal schnell über 150% (es müssen wohl mehrere CPU Kerne am Decoding nagen), aber immer noch fließend. Der VLC soll angeblich in der Lage sein außerhalb des Desktops genutzt werden zu können, also z.B. um für eine Lade-animation. Der omxplayer welcher in einigen Docs noch beworben wird, ist schon seit einem Jahr oder mehr deprecated. Idealerweise liegt die Bootzeit bei unter drei Sekunden, behaupte ich mal so, und in dieser Zeit sollte etwas angezeigt werden - wird nicht so einfach und drängt auch nicht, muss aber gemacht werden :wink:
Antworten