Webserver bzw. Problem mit SendNetworkData()

In dieser Linux-Ecke dürfen nur Themen rund um Linux geschrieben werden.
Beiträge, die plattformübergreifend sind, gehören ins 'Allgemein'-Forum.
Benutzeravatar
HeX0R
Beiträge: 2953
Registriert: 10.09.2004 09:59
Computerausstattung: AMD Ryzen 7 5800X
96Gig Ram
NVIDIA GEFORCE RTX 3060TI/8Gig
Win10 64Bit
G19 Tastatur
2x 24" + 1x27" Monitore
Glorious O Wireless Maus
PB 3.x-PB 6.x
Oculus Quest 2
Kontaktdaten:

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von HeX0R »

Ich kann das nicht bestätigen.
Bei mir läuft seit Jahren ein PB-Tool unter Debian auf nem VServer (als SMTP tunnel), das ist weder jemals abgestürzt, noch war der Port geblockt, wenn ich es mal neu gestartet habe (also richtig beendet und neu gestartet, nicht "abgeschossen").
Benutzeravatar
mk-soft
Beiträge: 3680
Registriert: 24.11.2004 13:12
Wohnort: Germany

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von mk-soft »

Bei macOS habe ich es auch manchmal das der Server-Port nicht sofort verfügbar ist.
Einfach eine loop mit Delay programmieren bis das System den Port wieder frei gibt.

War schon irgendwo als Bug gemeldet.
Alles ist möglich, fragt sich nur wie...
Projekte ThreadToGUI / EventDesigner V3 / OOP-BaseClass-Modul
Downloads auf MyWebspace / OneDrive
stevie1401
Beiträge: 659
Registriert: 19.10.2014 15:51
Kontaktdaten:

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von stevie1401 »

Ich habe das heute einmal mit einer loop-Schleife getestet. Aber als der Server nach 10 Minuten immer noch nicht wollte, gab ich auf. Erst als Linux neu gestartet war, ging der Port wieder.
Ich programmiere nur noch mit Linux.
Linux Mint 21.x
Benutzeravatar
mk-soft
Beiträge: 3680
Registriert: 24.11.2004 13:12
Wohnort: Germany

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von mk-soft »

Das is eine anderes Problem und hat nichts mit PB zu tun ...
Eventuell das Program lief im Hintergrund weiter, oder der Port wird von etwas anderen benutzt.

Das System räumt normaler weise dieses innerhalb einer Minute auf ...
Alles ist möglich, fragt sich nur wie...
Projekte ThreadToGUI / EventDesigner V3 / OOP-BaseClass-Modul
Downloads auf MyWebspace / OneDrive
Benutzeravatar
NicTheQuick
Ein Admin
Beiträge: 8672
Registriert: 29.08.2004 20:20
Computerausstattung: Ryzen 7 5800X, 32 GB DDR4-3200
Ubuntu 22.04.3 LTS
GeForce RTX 3080 Ti
Wohnort: Saarbrücken
Kontaktdaten:

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von NicTheQuick »

stevie1401 hat geschrieben:Ich habe das heute einmal mit einer loop-Schleife getestet. Aber als der Server nach 10 Minuten immer noch nicht wollte, gab ich auf. Erst als Linux neu gestartet war, ging der Port wieder.
Ich glaube das Standard-Timeout ist hierfür 120 Sekunden. Spätestens dann sollte der Port also wieder frei sein. Falls das nicht der Fall ist, dann läuft der Prozess definitiv noch im Hintergrund. Gib dazu im Terminal folgenden Befehl ein: netstat -tlnp
Dann siehst du sowas:

Code: Alles auswählen

(Es konnten nicht alle Prozesse identifiziert werden; Informationen über
nicht-eigene Processe werden nicht angezeigt; Root kann sie anzeigen.)
Aktive Internetverbindungen (Nur Server)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      1779827/nc          
tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      -                   
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      -                   
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      -                   
tcp        0      0 127.0.0.1:5943          0.0.0.0:*               LISTEN      -                   
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      -                   
tcp        0      0 127.0.0.1:9050          0.0.0.0:*               LISTEN      -                   
tcp        0      0 0.0.0.0:873             0.0.0.0:*               LISTEN      -                   
tcp6       0      0 :::1716                 :::*                    LISTEN      15113/kdeconnectd   
tcp6       0      0 :::22                   :::*                    LISTEN      -                   
tcp6       0      0 ::1:631                 :::*                    LISTEN      -                   
tcp6       0      0 ::1:25                  :::*                    LISTEN      -                   
tcp6       0      0 :::873                  :::*                    LISTEN      -
In der vierten Spalte siehst du Adresse und Port eines lauschenden Serverprozesses und in der letzten Spalte der dazugehörige Prozess. Bei mir lauscht zum Beispiel gerade netcat (nc) auf Port 8080 auf allen IPv4-Interfaces (0.0.0.0). Die Prozessnamen siehst du aber nur, wenn du die Prozesse auch mit den Rechten deines aktuellen Nutzers gestartet hast. Ansonsten siehst du als root auch alles.
Bild
stevie1401
Beiträge: 659
Registriert: 19.10.2014 15:51
Kontaktdaten:

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von stevie1401 »

Mit Purebasic6 Beta 6 ist das Problem leider nicht behoben.
Hat jemand inzwischen eine Lösung gefunden?
Gibt es nicht einen Linux-Befehl, der den blockierten Port wieder freigeben kann?
Ich programmiere nur noch mit Linux.
Linux Mint 21.x
Benutzeravatar
NicTheQuick
Ein Admin
Beiträge: 8672
Registriert: 29.08.2004 20:20
Computerausstattung: Ryzen 7 5800X, 32 GB DDR4-3200
Ubuntu 22.04.3 LTS
GeForce RTX 3080 Ti
Wohnort: Saarbrücken
Kontaktdaten:

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von NicTheQuick »

Anfang des Jahres hat Fred zu dem Problem geschrieben, dass er sich das anschauen muss: https://www.purebasic.fr/english/viewto ... 37#p614237
Bild
stevie1401
Beiträge: 659
Registriert: 19.10.2014 15:51
Kontaktdaten:

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von stevie1401 »

Der Fehler ist mit Version 6.10 beta 6 endlich behoben :)
Ich programmiere nur noch mit Linux.
Linux Mint 21.x
Benutzeravatar
mk-soft
Beiträge: 3680
Registriert: 24.11.2004 13:12
Wohnort: Germany

Re: Webserver bzw. Problem mit SendNetworkData()

Beitrag von mk-soft »

War kein Fehler sondern eine Standard Eigenschaft von Linux und macOS die man ändern kann
Alles ist möglich, fragt sich nur wie...
Projekte ThreadToGUI / EventDesigner V3 / OOP-BaseClass-Modul
Downloads auf MyWebspace / OneDrive
Antworten